PDA

View Full Version : HV-85 esc help needed


adwb
11-22-2006, 06:37 PM
Please can any one suggest what settings on the castlelink software for the following equipment.

Z-power 50t kv-600 motor with a Phoenix HV-85 esc and a 10s A123 battery pack fitted to a Raptor 30.

or

supply a contact for Phoenix as they don't answer emails sent via the support link on their web site.

thank you

adwb

Joe Ford
11-22-2006, 07:28 PM
adwb...I answer 99% of the emails here at "the castle"...haven't received one from you for some reason??? Load up the 1.54 software. Settings should be as follows:

soft cutoff
heli fixed or governor high
brake functions are disabled when you choose a heli mode
motor start power med
throttle response low
low timing advance
PWM 13KHz
current limiting disabled
gov gain and spool up speed you'll have to test...start w/factory and adjust as needed/desired

Make SURE you read the instructions on how to setup your transmitter (you should have printed this when you downloaded the new software...it's on the 2nd page that pops up when you download the Castle Link 2.20 software)

adwb
11-23-2006, 08:04 AM
Joe thank you for he information.
FYI I have emailed this query 3 times to your support email address from your website the last time being at the same time as this query was logged.
Maybe there is a problem somewhere?
many thanks
Alistair

Motions
11-23-2006, 12:52 PM
I highly suggest you use standard timing for this motor.

adwb
11-23-2006, 01:21 PM
Scott,
why do you suggets that it seems to be different form suggestions else where?
Alistair

Motions
11-23-2006, 02:41 PM
I was told by Gary at TPPacks. I tried low timing when I set mine up but on the Z-power motor it loses quite a bit of power and doesn't run very well. Standard timing is what this motor needs to be optimum.

adwb
11-23-2006, 05:38 PM
Ok thank you for the advice.
Alistair
I was told by Gary at TPPacks. I tried low timing when I set mine up but on the Z-power motor it loses quite a bit of power and doesn't run very well. Standard timing is what this motor needs to be optimum.

berniew
12-02-2006, 12:00 AM
Be sure to read the heli software set up page before the download page. It says 'Print This Page for Reference' and goes throught the steps for heli set up with any software above 1.50.

http://www.castlecreations.com/downloads/cl_beta_info.html

Bernie

Rugar
12-03-2006, 04:43 PM
Hi Bernie,
Good to see that you signed up and are posting here.
Welcome to WattFlyer!