PDA

View Full Version : Berg 7 Cuts Out With External Battery


NCC1700
03-11-2007, 11:01 PM
I am trying to get my Berg 7 receiver to work with an external battery pack.

When I plug in the pack to channel 7 (the only empty one for my setup) there is a slight high pitch noise (very, very soft) and the servos twitch or move into strange positions then everything stops working.

What am I doing wrong?

Joe Ford
03-14-2007, 08:59 PM
Does it do this when plugged into other channels? Do you have a speed controller plugged in as well? Is the BEC disabled on it? Is the pack fully charged? Polarity is correct? Let me know.

NCC1700
03-14-2007, 09:22 PM
No speed controller plugged in but I did cut the center wire.

All the other servos are plugged in however it also will do this with individual servos.

Full pack.

The setup works perfectly with a speed controller plugged in with no receiver battery. Go figure.

Joe Ford
03-15-2007, 06:27 AM
??? No ESC but center wire cut? That would be the positive (red) wire and prevent any power from reaching the receiver? Please advise. Should be the LEFT wire cut (signal wire...either orange, yellow, or white depending on the mfg you use)...center wire and wire on the right should be connected.

NCC1700
03-15-2007, 02:16 PM
I want to disable the BEC. The instructions for my castle 60 say to cut the red wire (middle) to do this.

When I plug the receiver battery into channel 7 on my Berg I can move the servos for about two minutes then the receiver makes a high pitched noise and all the servos curl into strange positions.

If I use a non-altered ESC and power the servos through that all is fine.

Bear in mind that in both tests I did not connect the main battery for the motor to the receiver.

Joe Ford
03-17-2007, 05:03 AM
AH! Ok...thought you meant on the battery pack...figured you were wiring up your own rx pack like I do. ;) If you plug the battery pack into a different channel what does it do? Any chance you have the Castle Link to plug into? When the servos curl does a red LED on the Berg 7 come on? Is this inside or outside? Make a difference when you go to the other environment? Let me know.

NCC1700
03-17-2007, 06:56 PM
Well it makes no difference on the receiver channel . . . they are all crazy with this set up.

I finally installed a Sport BEC and flew today (PTS P-51 electric conversion) and all went off without a hitch.

Would the Castle Link let me troubleshoot this receiver battery nonsense?

Also is the Castle Link the same product for programming both the Berg 7s as well as your line of speed controllers?

Thanks,

Greylids