PDA

View Full Version : power pulg to blade cx question


rmbler
12-06-2005, 05:11 AM
hi all a quick question re: the power plug to the bcx as with the bcp i am suppose to disconnect the motor from the 4 in 1 unit but it seems really hard to get a grip on it and i am worried that i might damage the unit or plug has anyone else experienced this and if so any hints as to what made it disconnect easier.

thank you.
Regards,
Phil.

zappedalaskan
12-07-2005, 02:55 AM
HI Phil,
I just got my CX today and I like it a lot. I unplugged the two leads like it says. I used needle nose pliers, and reached down from the top and pulled them out. there are only the two right there. But... When I plugged them back in, it seemed like the top one went one way and I plugged it in and slowly brought the motor up and the top blade went backwards. I was glad I left the canopy off to check this first :) I unplugged it and flipped it over and popped it back on the prongs. They come off pretty easy and it is good to do. (to double check for factory slips or shipping knocks) and know your controls are at least going the right directions. the harness holds them right there and like I said, if you put it back the wrong way you it won't hurt anything. Just give it a flip. Be sure the rotors are going the proper direction before you put the canopy back on. Hope this helps
Regards,
Jay

rmbler
12-13-2005, 05:20 AM
jay......... thank you for the help with the plug thing i have one more question for you Guys i can fly a bit on the bcp and no problems with the coaxial ones i have here it is my blade cx seems to pirouette to the right really fast and hardly at all to the left i mean really slow i know its a simple adjustment but have no idea how any help would be greatly appreciated

Regards,
Phil