PDA

View Full Version : ESC started on fire!


foresterxt
01-16-2006, 07:41 PM
Okay, I'm new to electric but I've been flying nitro for a while. So anyway, I picked up a spectra ARF along with the elecrifly motor/ESC/gearbox kit. I installed everything as per the direction. I got all the electronics in the plane and decided to give it test. I'm using a brand new 3200mah 7-cell NiMh battery by the way. Everything was working great during my minute or two of testing the motor and throttle control. I was amazed at the amount of torque the gearbox generates with the 12" folding prop!

So now that everything seemed to be working properly, I wanted to run some timed motor tests to see how much run time I could expect in the air. So about 5 minutes into my run test I notice smoke, I look inside the compartment to see my ESC was on fire! What the heck went wrong here?!? The ESC wasn't wrapped in anything to cause it to overheat. The 30-amp ESC with the matched motor should have been fine. Was my 3200mah 7-cell batter too much?

Thanks,

Dave

Mike Parsons
01-16-2006, 08:58 PM
Dave,
Thanks for taking the time to share your experience with everyone. Please only start one thread as duplicating threads in seperate areas is considered Cross Posting. Cross posts can get confusing for the members as well as yourself having to maintain two seperate threads. I have merged the posts out of this thread and into the duplicate thread in Power systems http://www.wattflyer.com/forums/showthread.php?t=3778.

Thanks for you help in this matter!

Cheers,
Mike