PDA

View Full Version : Motor short circuiting?


earthsciteach
09-02-2011, 01:40 AM
My 800 mm Spitfire does not like to fly. The latest issue is a strangely behaving motor. Today, I connected the battery in the Spit, prepared to hand toss her, but she just didn't have much power. I checked the battery (7.4 V-1300 mah, 2S batt) and it was fully charged (8.2 V). Reconnected, throttled up and the motor barely twitched. Disconnected everything, reconnected, throttled up and had power. Throttled back to switch hands to toss and when I gave her throttle, nothing but twitching.

At home I removed the motor and esc. Had intermittent power. Only thing I can think of is that the leads coming off of the motor are shorting out by touching the motor base/housing. Is this a common thing?

kyleservicetech
09-02-2011, 02:31 AM
My 800 mm Spitfire does not like to fly. The latest issue is a strangely behaving motor. Today, I connected the battery in the Spit, prepared to hand toss her, but she just didn't have much power. I checked the battery (7.4 V-1300 mah, 2S batt) and it was fully charged (8.2 V). Reconnected, throttled up and the motor barely twitched. Disconnected everything, reconnected, throttled up and had power. Throttled back to switch hands to toss and when I gave her throttle, nothing but twitching.

At home I removed the motor and esc. Had intermittent power. Only thing I can think of is that the leads coming off of the motor are shorting out by touching the motor base/housing. Is this a common thing?

Maybe this might help?

http://www.wattflyer.com/forums/showthread.php?t=35216

earthsciteach
09-02-2011, 02:37 AM
Thank you! I'll check it out tomorrow!