WattFlyer RC Electric Flight Forums - Discuss radio control eflight

WattFlyer RC Electric Flight Forums - Discuss radio control eflight (http://www.Wattflyer.com/forums/index.php)
-   RC Radios, Transmitters, Receivers, Servos, gyros (http://www.Wattflyer.com/forums/forumdisplay.php?f=68)
-   -   hitec 05s micro receiver and futaba radio (http://www.Wattflyer.com/forums/showthread.php?t=62893)

andyrew 07-05-2011 01:36 AM

hitec 05s micro receiver and futaba radio
 
hi all,
i have 2 hitec 05s micro receivers that i am trying to use with my planes and a futaba 9z and futaba 8uap, both using synthesizer modules (one futaba, one hitec).

for some reason i cannot get either radio to work correctly with the receivers. they are on the correct channel, they are in ppm mode and they are transmitting. every now and then when i power up the planes, the radios will control them correctly. mostly the servos just all go nuts and the channels dont match up correctly (suddenly the ailerons are on the elevator stick, etc).

anyone know what might be causing this? is there an issue where these receivers just don't work with futaba radios? or am i going to have the same issue with a futaba receiver? i have tried everything and just can't figure it out.

thanks,
andy

slipstick 07-05-2011 08:17 AM

Where are you and what frequency band are you using ?

Those receivers normally work fine with Futaba Txs. Do you have the correct Hitec crystals in the Rxs ?

Do the Txs work correctly with any other Rxs ? That's surely the first thing to check. I've heard of some initialisation problems with the 9Z modules though mainly when used with Berg Rxs. And of course the Hitec Spectra module isn't designed to be used in a Futaba Tx so if it ever did work that would just be good luck (and if you're in the US on 72MHz it's technically illegal to use a module from a different manufacturer in a Tx).

Steve

andyrew 07-05-2011 12:07 PM

both tx's work fine with every other receiver. i've never had an issue until these two.

i did some research and found some dealer that said they aren't compatible with a 9z if you're using the synth module. i don't know if that's true or not, but so far, he's right :) as for the other one, i don't know why it won't work.

as far as the crystals... that one i don't know. i don't know if they're hitec or not. i bought them as a flight pack from tower and had the xtal included. i can only assume they sent me what should have been the correct crystal. but on the xtal label i can't tell what it is. it's just got a channel # and freq. i can't see anywhere where it tells me a brand or if it's single or dual conversion. does it need to be specifically made by hitec?


All times are GMT +1. The time now is 05:47 AM.

Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Page generated in 0.07797 seconds with 13 queries