View Single Post
Old 01-09-2014, 03:22 PM   #1
solentlife
Super Contributor
 
solentlife's Avatar
 
Join Date: Oct 2010
Location: Ex UK Brit now in Latvia west coast - Ventspils
Posts: 5,863
View solentlife's Gallery47
Thanked 225 Times in 222 Posts
Club: Founder Member Ventspils RC Club. Ex Waltham Chase and Meon Valley Soaring.
Awards Showcase

Scratchbuilders Award  Scratchbuilders Award  Outstanding Contributor Award  125mph Speed Demon 
iTrader: (0)
Friends: (15)
Default My 9xr stopped working !

So I get home and I see the 'box'....

I open up and there's the 9xr ... initial impression - looks OK.

Plug in FrSky ... install the 'special' 9xr LiPo .... switch on ...

Usual "Switch Error" .... and start programming.

Before completion of Model 1 .. I have to switch off and do 'domestic' things.

Next day - switch on ... ?? Only READY light at top comes on ... no Menu .. no Screen ... no Switch Error ... nothing.

I contact HK via Live Chat ... have RMA number .. sent photo ... now wait to hear from them.

The address label they gave - is UK ... not HK ... so at least that's a bit better than sending to China .. but they say do not send back till they check initial report / photo I sent in ...

Lets see what happens.

Nigel

222kph PKJ,EDF Concorde, Mini4,Mig3,T45,PKJ twin,ME109,Edge540,Cessna182,Skymaster Biplane,F15,F16,Badius,Ultimate,SE5,Qbee10,450 Heli,V911,J3 Cub Founder 9x forum: http://groups.yahoo.com/group/Flysky_RC_radio/
- Subscribe my Youtube: "solentlifeuk"
solentlife is offline  
  Reply With Quote
 
Page generated in 0.09321 seconds with 17 queries