Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Multi-Rotors
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

Multi-Rotors Discuss your quad copters and other multi engined choppers here.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 03-18-2014, 12:55 AM   #1
tehlump
Member
 
tehlump's Avatar
 
Join Date: Sep 2010
Location: Huntsville, TX
Posts: 134
Thanked 4 Times in 3 Posts
iTrader: (0)
Friends: (2)
Default Point me in the right direction diagnosing a quad problem?

Hello everyone,

I am new to quadcopters, dove in headfirst and bought a kit from rctimer, the 450 sized spider quadcopter. Here's what I have:

http://www.rctimer.com/product_1061.html

RCtimer spider quad frame
arduflyer 2.5.2 updated to 3.0.1 arducopter (I think that's the version, it's the latest version I have uploaded)

I got it built and took it up for its first flight yesterday. It flew and was controllable but had a very severe wobble or oscillation. I searched around and figured it was a PID problem. By default the values were:

P-.1500
I-.1000
D-.0040

I watched a couple of youtube videos explaining what the PID look was and figured I was now a PID expert! I changed the P value to .1200, attempted another flight and it promptly flipped upside down on its back. Obviously I have no idea what I'm doing so I was hoping for a nudge in the right direction.

After reading and watching some more videos for similar problems I began to suspect that my problem was more vibration related. It turns out one of my prop adapter shafts wasn't true, this caused a nasty vibration so I figured if I sorted that out it would improve things. My neighbor is a machinist so he got that sorted out. Running the motors without props now is very smooth.

So I attempted another flight today with my neighbor filming so I could get the expert's opinion on what I need to address first.

https://www.youtube.com/watch?v=3OMvnN-WEh0

As you can see, the problem is bad. I have reset the default PID values I stated above, those values were in effect for that flight. At first I thought the wobble was purely roll related but having watched it for a bit it seems to be rotating around like a quarter spinning on a table.

The vibration log shows that X and Y are staying below +-3 and probably closer to +-2, the Z is centered on -10 and stays within -8/9 and -11 or so

Thanks in advance!
tehlump is offline  
  Reply With Quote
Old 03-19-2014, 12:55 AM   #2
tehlump
Member
 
tehlump's Avatar
 
Join Date: Sep 2010
Location: Huntsville, TX
Posts: 134
Thanked 4 Times in 3 Posts
iTrader: (0)
Friends: (2)
Default

For anyone who has a similar problem...

I spoke with a couple of more experienced users who both said that the wobble in the video seemed to almost definitely be a symptom of a too high P value.

Over a number of trials I ended up settling on a P value of .0500 and the shaking is gone. It's flying smooth as glass now!
tehlump is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Multi-Rotors

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WBC #10 inquiry.. Are you ready for a quad? Nitro Blast General Electric Discussions 2 10-28-2011 06:48 PM
Glitch / lock out problem!!!! Gee Power Systems 20 04-14-2011 03:29 AM
Unpossible servo problem mclarkson RC Radios, Transmitters, Receivers, Servos, gyros 13 02-13-2011 12:45 PM
Went looking for my lost T-28 SHADY General Electric Discussions 26 02-03-2011 11:30 PM


All times are GMT +1. The time now is 01:17 AM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.23293 seconds with 21 queries