Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > General RC E-Heli Talk
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

General RC E-Heli Talk General discussion forum for electric powered rc helis.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 09-03-2014, 03:22 AM   #1
nopeda
New Member
 
Join Date: Mar 2012
Posts: 11
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default Hubsan X4 questions

I've recently damaged a Hubsan X4 by hitting a cable with it and it fell hard about 30' onto an asphalt parking lot. It landed upside down and the blades were turning wide open, so I had to disconnect the power wires to shut it down. After that when the power wires are connected the blue LEDs blink alternating left and right, then when the transmitter is turned on they blink together. The transmitter LED turns green saying they are communicating, but the copter won't respond and the blue LEDs keep blinking. Can anyone tell me if there's a way to fix whatever is wrong?
Also, I don't have whatever it takes to make the camera work. There's a slot to insert something but I don't have it, and if it came in the package I accidentally threw it away without ever seeing it. Can anyone tell me what to get in order to get the camera working, and also if there are any tricks I need to know about?

Thank you for any help!
David
nopeda is offline  
  Reply With Quote
Old 09-03-2014, 04:22 AM   #2
pizzano
Behold The Renaissance
 
pizzano's Avatar
 
Join Date: May 2012
Location: So. Calif
Posts: 1,199
Thanked 76 Times in 74 Posts
Club: AMA, Marks, Pomona Valley, Prado Dam
iTrader: (0)
Friends: (3)
Default

Sorry to hear that nopeda......Unfortunately, there could be a number of things that got damaged. It's such a small craft, the electronics are very fragile....without seeing the damage, there's no way for us to assess the problem.

If it landed upside down hard from a height of 30', all of the operating system control board took the brunt of the impact........as well as some of the motor shafts.....the antenna might have come loose, the CB could be cracked, a motor shaft could be jammed, an ESC may be fried.....ect, ect, ect.....there's to many (if's) to help you out much....sorry.

AMA 928214
pizzano is offline  
  Reply With Quote
Old 09-03-2014, 11:14 PM   #3
nopeda
New Member
 
Join Date: Mar 2012
Posts: 11
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default

Originally Posted by pizzano View Post
Sorry to hear that nopeda......Unfortunately, there could be a number of things that got damaged. It's such a small craft, the electronics are very fragile....without seeing the damage, there's no way for us to assess the problem.

If it landed upside down hard from a height of 30', all of the operating system control board took the brunt of the impact........as well as some of the motor shafts.....the antenna might have come loose, the CB could be cracked, a motor shaft could be jammed, an ESC may be fried.....ect, ect, ect.....there's to many (if's) to help you out much....sorry.
I was hoping the way the lights are blinking would mean something to some people in some of these forums. I've asked in seven and this is the only reply I've gotten. No one has been able to tell me anything about what I need to use the camera either. I expected a number of replies to consider, but instead there are none. It hasn't been 24 hours yet though, so maybe something will turn up in one of the groups. Whether I get anything helpful or not I'm convinced there are some people somewhere who would be able recognise something from the way the lights are behaving, and who could tell me about the camera. I may never hear from any of them, but I feel sure they're out there somewhere.
nopeda is offline  
  Reply With Quote
Old 09-04-2014, 01:55 AM   #4
pizzano
Behold The Renaissance
 
pizzano's Avatar
 
Join Date: May 2012
Location: So. Calif
Posts: 1,199
Thanked 76 Times in 74 Posts
Club: AMA, Marks, Pomona Valley, Prado Dam
iTrader: (0)
Friends: (3)
Default

nopeda....

I won't go into all of the (why's) related to lack of responses......but it's more than likely related to the type of question(s) and descriptions given......like I stated previously, none of us are mind readers and without actually putting our hands on the damaged quad, any solution to the problem would just be a wild guess!

Part of the problem is also related to the poor quality and lack detailed information provided in the owner's manual.......here are three examples of owners manuals that each state are for the Hubsan X4....each is different and only one mentions flashing blue LED's, which evidently is related to the accelerometor level calibration....and we wonder why the "inexpensive" toys are so popular.....lol

http://www.rcgroups.com/forums/attac...mentid=5321293

http://brchobbies.co.uk/catalog/imag...4_guide_v2.pdf

http://www.firstpersonview.co.uk/fil...107DManual.pdf

As far as camera set-ups.....evidently there is a verison of this model that has an on board (video) camera installed and a version without the camera, there are aftermarket attachments also available for both the TX and quad related to FPV......all made by Hubsan and two other companies. These items do not come with a stock Hubsan 4x w/wo camera......my best quess with this is web search Hubsan 4x for video details and go from there.

Quite frankly nopeda, the vast majority that would be willing and able to help out, generally will not take the time to weed through the possible remedies to fix your issue because the quad is a "toy", not very dependable, and meant to play with and not a serious investment, meant to throw away once one can no longer repair (fly) or has out grown.

Keep hitting up the RCGroups forum, there are plenty of folks over there that have been through the issues with the Hubsan 4x and have moved onto better "toys"......just search the threads......I did briefly, and came up with several related articles......

AMA 928214
pizzano is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > General RC E-Heli Talk

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HITEC customer sevice is very good,very helpful to talk to asking questions. tobydogs RC Radios, Transmitters, Receivers, Servos, gyros 2 10-02-2013 12:44 AM
Hubsan X4 mini quadcopter FPV madflyer UAV / FPV 0 02-11-2013 03:26 PM
Couple of newb su26xp questions M@! Indoor & Micro Electric Planes 2 06-22-2011 04:44 PM
HiTec X4 Charger - At Field Power Source...Ideas ? Cole Mayfield Batteries & Chargers 33 05-19-2011 12:18 PM
Newbie With Questions......Sorry!! SNIPERWOLF Beginners 10 01-25-2011 12:56 AM


All times are GMT +1. The time now is 02:03 AM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.18105 seconds with 25 queries