Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > R/C Electric Topics - General > Flight Simulators
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

Flight Simulators Discuss computer flight simulators here

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 02-24-2013, 03:17 PM   #1
Monti
Spinless Loser Newb
 
Monti's Avatar
 
Join Date: Dec 2008
Location: Brantford, ON
Posts: 40
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (1)
Default Phoenix problems.... need help

Hi Peeps,

I bought Phoenix RC in 2008 and got version 2.00N. It worked at the time. When Vista came out, I went up to level 2.53 (I think) and got it to work again, some how.

Now after it being in active for a couple years, I want to reload it onto my new laptop but am having trouble. I can get the program loaded but the USB interface to my DX6i isn't being recognized properly in Windows 7 Ultimate. Windows loads a driver and tells me that it is working but the dongle just keeps flashing at me and the software doesn't see the controller. I tried a copy of Phoenix 3 and got the same result.

Does anyone have a work around?
Monti is offline  
  Reply With Quote
Old 02-25-2013, 10:37 PM   #2
Monti
Spinless Loser Newb
 
Monti's Avatar
 
Join Date: Dec 2008
Location: Brantford, ON
Posts: 40
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (1)
Default

Bump!
Monti is offline  
  Reply With Quote
Old 02-27-2013, 03:22 AM   #3
robschonk
Member
 
robschonk's Avatar
 
Join Date: Oct 2012
Posts: 23
Thanked 2 Times in 2 Posts
iTrader: (0)
Friends: (0)
Default

Try upgrading to version 4. It should ask you if you want to upgrade when you boot it up. Free upgrade.
robschonk is offline  
  Reply With Quote
Old 02-27-2013, 12:50 PM   #4
Monti
Spinless Loser Newb
 
Monti's Avatar
 
Join Date: Dec 2008
Location: Brantford, ON
Posts: 40
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (1)
Default

Thanks Robshonk...

I tried that. It won't install the updates unless the dongle is identified.

I have contacted the support staff aty Horizon Hobby. They rep both the DX6i I am running and the Phoenix Software from some place in Illinois. I should hear back in a few days whether this will go or not.

For some reason, I seem to be missing a King to my Straight. Hopefully they can sort it out.
Monti is offline  
  Reply With Quote
Old 02-27-2013, 03:27 PM   #5
robschonk
Member
 
robschonk's Avatar
 
Join Date: Oct 2012
Posts: 23
Thanked 2 Times in 2 Posts
iTrader: (0)
Friends: (0)
Default

Originally Posted by Monti View Post
Thanks Robshonk...

I tried that. It won't install the updates unless the dongle is identified.

I have contacted the support staff aty Horizon Hobby. They rep both the DX6i I am running and the Phoenix Software from some place in Illinois. I should hear back in a few days whether this will go or not.

For some reason, I seem to be missing a King to my Straight. Hopefully they can sort it out.
I'm using a DX5 with mine running Windows 7, and it works fine.

You can go to the Phoenix download page and download a file to manually update v3 to v4. Last file at the bottom of the page.

http://www.phoenix-sim.com/downloads.asp
robschonk is offline  
  Reply With Quote
Old 02-27-2013, 10:26 PM   #6
Monti
Spinless Loser Newb
 
Monti's Avatar
 
Join Date: Dec 2008
Location: Brantford, ON
Posts: 40
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (1)
Default

Thanks for that. I am now at Version 4.0M and the dongle is still flashing at me. I don't even need to run the program or connect my radio and the dongle flashes at me. Phoenix does not see the radio.

Could you do me a favor? Open your device manager and see if you can tell what driver you are using to drive your USB dongle? I am sure that is the issue but I don't know what I am looking for when I go to down it online.

Monti
Monti is offline  
  Reply With Quote
Old 02-27-2013, 11:29 PM   #7
robschonk
Member
 
robschonk's Avatar
 
Join Date: Oct 2012
Posts: 23
Thanked 2 Times in 2 Posts
iTrader: (0)
Friends: (0)
Default

Originally Posted by Monti View Post
Thanks for that. I am now at Version 4.0M and the dongle is still flashing at me. I don't even need to run the program or connect my radio and the dongle flashes at me. Phoenix does not see the radio.

Could you do me a favor? Open your device manager and see if you can tell what driver you are using to drive your USB dongle? I am sure that is the issue but I don't know what I am looking for when I go to down it online.

Monti
PM sent
robschonk is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > R/C Electric Topics - General > Flight Simulators

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale Phoenix Sim cable needs repair molokaiboy General RC items forsale forum 0 01-20-2013 06:00 AM
Sold Phoenix 25 with PHX-link in Excellent Condition DTB Motors and Speed Controllers for sale & WTB 3 05-06-2012 01:15 PM
Phoenix and Mode 1 Vs Mode 2 WalneyCol Flight Simulators 2 10-28-2011 02:21 AM
For Sale ParkZone T-28 Local To Phoenix / Scottsdale RoadKingAl General RC items forsale forum 0 04-09-2011 02:17 AM
Phoenix - Where are the fixed wing? Merritt Flight Simulators 8 04-06-2011 03:49 AM


All times are GMT +1. The time now is 12:26 PM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.16415 seconds with 33 queries