Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Micro Sized Electric Helicopters > E-Flite Helicopters
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 06-14-2011, 04:16 AM   #1
DynahoeDave
New Member
 
Join Date: Jun 2011
Posts: 2
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default CX Main hub question

Hi everyone,

I have a CX with the aluminum upgrades. The part that hold the lower blades can turn on the hub, but I see no set screws to lock it in place. The 4 that secure the whole bigger aluminum part to the outer shaft are tight.

I'm trying to find out what's not right here...
Click image for larger version

Name:	Heli 001.jpg
Views:	44
Size:	64.9 KB
ID:	149503

Click image for larger version

Name:	Heli 002.jpg
Views:	43
Size:	38.4 KB
ID:	149504

Straight, flies ok.

Click image for larger version

Name:	Heli 003.jpg
Views:	38
Size:	44.9 KB
ID:	149505

Twisted, flies not so good...


Thank you in advance,
Dave


DynahoeDave is offline  
  Reply With Quote
Old 06-23-2011, 03:40 AM   #2
DynahoeDave
New Member
 
Join Date: Jun 2011
Posts: 2
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default

So I adjusted things a bit. Discovered that if the piece that moves [it has the pins that the blades twist on] around is pushed up, there are little tabs that prevent it from turning. But there seems to be nothing to keep it up against those parts.

What am I missing?
DynahoeDave is offline  
  Reply With Quote
Old 01-15-2012, 11:52 PM   #3
cjg
Member
 
Join Date: Nov 2006
Posts: 210
Thanked 12 Times in 11 Posts
iTrader: (0)
Friends: (0)
Default

As I remember, the lower hub of the stock has a set secs that goes into a hole in the outer shaft. However, its been 2 years since I last had mine apart.

CJG
(HZ Supercub, PZ T-28 Trojan, Eflite BCX, PZ 210 Micro, UM P-51, UM T-28 and bunch of R/C trucks)
cjg is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Micro Sized Electric Helicopters > E-Flite Helicopters

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmitter Lipo Voltage Diodes Question Aientonni Batteries & Chargers 13 04-18-2011 02:55 AM
Blade CP Pro Main Motor Bad?? dsmtuned E-Flite Helicopters 3 03-03-2011 03:11 AM
General Help Question jap71173 Beginners 5 02-28-2011 08:04 PM
R/C transmitter mods question sschevel Beginners 11 01-07-2011 04:21 AM


All times are GMT +1. The time now is 07:42 PM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.15599 seconds with 25 queries