Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Micro Sized Electric Helicopters > E-Flite Helicopters
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 04-06-2012, 12:47 PM   #1
ollie10
New Member
 
Join Date: Apr 2011
Posts: 15
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default V1 mcpx and V2

I have both versions of the MCPX,,, V2 flys great , V1 is my main problem , under full throttle the heli lifts off the ground the starts to spin out of control anti clockwise. I have change the following parts , 3 in 1 main board,, swash plate,, servo's,, tail boom extension ,, head dampeners,, completely checked it over , i have even changed some parts from V2 , still the same ,, I am using a DX6I , checked all settings , heli shop told me to lower the pitch settings , same fault , dont think it can be a controller fault , V2 flys great "HELP"
ollie10 is offline  
  Reply With Quote
Old 04-10-2012, 10:56 AM   #2
JHTPPX
New Member
 
Join Date: Apr 2012
Posts: 1
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default

Has the tail motor done a lot of work and is dying!
JHTPPX is offline  
  Reply With Quote
Old 04-10-2012, 11:18 AM   #3
ollie10
New Member
 
Join Date: Apr 2011
Posts: 15
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default mcpx

Brand new 3 days old
ollie10 is offline  
  Reply With Quote
Old 04-10-2012, 11:19 AM   #4
ollie10
New Member
 
Join Date: Apr 2011
Posts: 15
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default mcpx

i have even changed the complete tail assembly off V2 , no change
ollie10 is offline  
  Reply With Quote
Old 04-22-2012, 04:34 AM   #5
Gionir
New Member
 
Join Date: Jan 2012
Posts: 7
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default

Stupid question, have you double checked the connection of the tail to the board?

Otherwise you could try and solder the wires to the board like me,

pictures here

Gio
---
my RC blog
Gionir is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > Micro Sized Electric Helicopters > E-Flite Helicopters

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
brand new mcpx v2 vibration frustration cc83 E-Flite Helicopters 5 12-31-2011 11:58 PM


All times are GMT +1. The time now is 05:39 PM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.16209 seconds with 27 queries