Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > General RC E-Heli Talk
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

General RC E-Heli Talk General discussion forum for electric powered rc helis.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 11-24-2012, 11:55 PM   #1
Lone Beagle
New Member
 
Join Date: Dec 2010
Posts: 5
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default Blade CX battery issue

Not sure if it is the battery or the receiver. When I plug the battery in the LED blinks once and that is it. The battery is fully charged. I have tried it with the Tx on and off. Anybody have any suggestions?

THanks
Lone Beagle is offline  
  Reply With Quote
Old 11-25-2012, 12:06 AM   #2
Heli Jim
Grandpa, Golfer, Pilot
 
Heli Jim's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 1,402
Thanked 113 Times in 113 Posts
iTrader: (9)
Friends: (1)
Default

Could be a lot of things.

Which CX do you have? there's more than one.

How old is the battery? Did you ever over discharge it?

Have you crashed the heli:? There are a lot of different reasons
that you are seeing the problems with your CX.

The easiest to check would be to use a brand new battery
and see if the problem goes away. If it does, then it was
the battery that was the problem They do wear out over time
and I suspect that's your problem.

Helicopters don't really fly.......
They're just so ugly, that the earth repels them.
Heli Jim is offline  
  Reply With Quote
Old 11-25-2012, 12:11 AM   #3
Lone Beagle
New Member
 
Join Date: Dec 2010
Posts: 5
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default

It is a Scout CX.
The battery is only a few weeks old and has only been in a few flying sessions.
I will try another one.

Thanks
Lone Beagle is offline  
  Reply With Quote
Old 11-26-2012, 11:46 PM   #4
Lone Beagle
New Member
 
Join Date: Dec 2010
Posts: 5
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default Update

Ok it is a Scout CX and it is not the battery. I switched batteries and the helicopter did the same. One blink of the LED then nothing. The batteries work fine in a small airplane I have.

Any suggestions?

Thanks,
John
Lone Beagle is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > Electric Helicopters > General RC E-Heli Talk

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
100+ MPH Club CHELLIE Hi-Performance and Sailplanes 1955 08-20-2014 02:55 AM
Castle Creations / A123 Battery Backup system kyleservicetech RC Radios, Transmitters, Receivers, Servos, gyros 6 04-17-2012 03:55 PM
3 cell Lipo Batteries- Bang for the Buck dahawk General Electric Discussions 30 03-11-2012 01:40 AM
Noob Cant figure out how to match batteries to motors please help Otonzer Scratch and Kit Built Aircraft 7 02-26-2012 12:01 AM
Heli-Max Axe CX Nano - battery issue Air-on Micro Sized Electric Helicopters 5 12-18-2011 01:16 PM


All times are GMT +1. The time now is 02:29 PM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.14639 seconds with 25 queries