Wattflyer RC Network: RC Universe :: RCU Magazine :: RCU Forums :: RCU Classifieds :: RCU User Reviews :: RCU YouTube
Home Who's Online Calendar Today's Posts RealTime Post Spy Mark Forums Read
Go Back   WattFlyer RC Electric Flight Forums - Discuss radio control eflight > R/C Electric Topics - General > RC Radios, Transmitters, Receivers, Servos, gyros
Register Members List Wattflyer Extras Articles Search Today's Posts Mark Forums Read Social Groups

RC Radios, Transmitters, Receivers, Servos, gyros Discussion all about rc radios, transmitters, receivers, servos, etc.

Thank you for your support (hide ads)
Reply
 
Thread Tools Display Modes
Old 09-25-2013, 12:41 AM   #1
tobydogs
love to build!
 
tobydogs's Avatar
 
Join Date: Jan 2010
Location: nj usa
Posts: 3,035
Thanked 202 Times in 199 Posts
Club: rcrcc rockland county,ny
Awards Showcase

Outstanding Contributor Award 
iTrader: (0)
Friends: (17)
Default HITEC customer sevice is very good,very helpful to talk to asking questions.

i just want to compliment hitec corperatioon for their customer service.

I have been emailing hitec regarding questions on my new eclipes 7 tx and rxs I'm using and i must say...they have been getting back to me to answer questions right away and offered to send spc plugs free as i misplaced mine for 2 rx's.

the reason i may have crashed is something i discover today after work. i was connecting power to the esc to check conection,the ubec,and servos,motor when i heard a soft crackling sound in the electric wires...i knew it was a short somewhere so began wiggling wires. found right away the positive wire to the deans t plug on the esc was loose....not off by any means but loose enough to cause a broken circuit when giggled and the reconnect to fool me thinking all was ok ...this is also where my castle ubec is wired in near by. i figure the many plugging in and out to batteries for many flights wore it out. fixed now! thank goodness i didn't get it installed in the rebuilt edge 540t and have it work only to crash again.

another kudos goes to tower hobbies for shipping my replacement canopy for the 540t so quickly. i cant wait to put this bird back in the air and with all the good customer treatment i think it'll be quicker than thought.

thanks again hitec and tower!!!!! stu

narrow is the place to land...wide is the space to crash....choose the narrow way!
tobydogs is offline  
  Reply With Quote
Old 09-25-2013, 06:00 PM   #2
E-Challenged
Member
 
E-Challenged's Avatar
 
Join Date: Aug 2005
Location: Southern CA
Posts: 525
Thanked 22 Times in 20 Posts
iTrader: (0)
Friends: (1)
Default

Be very careful of polarity when connecting SPC pigtail to receiver. I have been flying with an Eclipse 7 with 2.4GHz module and about to learn the ins and outs of my new Aurora 9 touch screen programming. Hitec user manuals and instruction sheets have some mistakes/unclear stuff that are never corrected except by corrections and supplemental info in vendor forums etc. Use the HPP-22 PC interface andyour USB cable to keep transmitter and receiver software/firmware up to date.
E-Challenged is offline  
  Reply With Quote
Old 10-02-2013, 01:44 AM   #3
A.T.
Member
 
Join Date: Mar 2006
Location: New Zealand
Posts: 123
Thanked 23 Times in 21 Posts
Club: To many to include.
iTrader: (0)
Friends: (0)
Default

Originally Posted by tobydogs View Post
i just want to compliment hitec corperatioon for their customer service.
I have been emailing hitec regarding questions on my new eclipes 7 tx and rxs I'm using and i must say...they have been getting back to me to answer questions right away and offered to send spc plugs free as i misplaced mine for 2 rx's.
the reason i may have crashed is something i discover today after work. i was connecting power to the esc to check conection,the ubec,and servos,motor when i heard a soft crackling sound in the electric wires...i knew it was a short somewhere so began wiggling wires. found right away the positive wire to the deans t plug on the esc was loose....not off by any means but loose enough to cause a broken circuit when giggled and the reconnect to fool me thinking all was ok ...this is also where my castle ubec is wired in near by. i figure the many plugging in and out to batteries for many flights wore it out. fixed now! thank goodness i didn't get it installed in the rebuilt edge 540t and have it work only to crash again.
another kudos goes to tower hobbies for shipping my replacement canopy for the 540t so quickly. i cant wait to put this bird back in the air and with all the good customer treatment i think it'll be quicker than thought.
thanks again hitec and tower!!!!! stu
The following page may also be of benefit:

. Hitec Eclipse 7 & Eclipse 7 Pro - FAQ - Setup and Additional Programming

Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline  
  Reply With Quote
Reply

  WattFlyer RC Electric Flight Forums - Discuss radio control eflight > R/C Electric Topics - General > RC Radios, Transmitters, Receivers, Servos, gyros

« Previous Thread | Next Thread »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Let's talk about servos - Whatever is on your mind AEAJR Beginners 233 Yesterday 05:09 AM


All times are GMT +1. The time now is 03:40 AM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Charities we support Select: Yorkie Rescue  ::  Crohn's & Colitis Foundation



Page generated in 0.13846 seconds with 23 queries