View Full Version : New Motor and ESC Problem

09-06-2005, 04:13 PM
Hello all,

I just posted a question yesterday about the wiring of the Ultrafly brushless motor since there was no color-coding of its wiring, and I immediately got the answer I needed. Now there is a new problem!

I wired everything according to the instructions, double-checked, and even triple-checked it, yet it won't run the motor at all AND the ESC cannot be put into programming mode!

The speed control in use is the new Castle Creations Thunderbird 18. It is supposed to be ready to fly as-is from the package, but the motor doesn't run no matter what I do. I also tried multiple times to put it into programming mode, which is done by turning on the power with the Tx at full throttle, then following a series of stick movements (each being verified by special tones generated by the ESC through the motor).

The ESC never emits the sound that verifies it is "seeing" full throttle! I have tried reversing the throttle channel, adjusting the trim tab fully in the proper direction, making sure the flight battery is 100% charged, and even went into the Tx programming and adjusted the throttle endpoints to maximum (+150%) in each direction! Still, no response from the ESC other than to say it has power (it just sits there and beeps once every 5 seconds or so).

Since Castle Creations doesn't include any type of trouble-shooting guide with the ESC, and they don't have anything on their website for the Thunderbird series of controllers either, I was wondering if anyone else has experienced this problem?

Most likely I'll just take the thing back to my LHS where I got it yesterday and get a different controller, but I thought I'd post here first to see if anyone can suggest something obvious that I'm overlooking.


09-06-2005, 04:53 PM

Had a similar if not the same problem. My ESC also stayed inactive, the ESC has a safety cct in it and it must see the throttle in the zero position for 4 seconds when switching on so that motor won't suddenly start. Also my throttle travel adjust on my JR radio had to be 100% for full and no throttle.

Hope this is the answer.


09-06-2005, 04:58 PM
I had a similar problem with the first Castle Creations ESC I bought and called them and they walked me throught getting the ESC to work. Im my case the instructions for moving the stick left out one step, so I was never getting into programming mode.

I have since gotten their Computer interface, and use my laptop to get the setups done. They make a great product, and stand behind it. If you are going to buy more than one of the controllers, the computer interface is a good way to go. I have 4 of their ESC's and it really is easy to get them right with the computer displaying the information.

09-06-2005, 06:33 PM
I just got back from my LHS and letting them test it out. They got the same results, so they exchanged it for another unit. I just hooked this one up and it works perfectly, so obviously the first one was simply defective.

Thanks for the replies and feedback, but the problem is now solved!