View Full Version : Phoenix 35 Problems

01-29-2007, 03:03 AM
I just connected my Phoenix 35 up, when I power up the speed control all I get is a rapidly blinking red light and am hearing no beeping whatsoever, it is connected to the motor and receiver properly. Does anyone have a clue why this is happening? I've checked my throttle and reversed it, still nothing. Im not even getting the normal light on my receiver like it is getting power or linking up with my dx6. I am connecting the speed control to a 2100 15c 3 cell LiPo and a Hacker A20 xl6. If anyone has any ideas other then to contact CC tomarrow they would be extremely appreciated.


Joe Ford
02-03-2007, 09:12 PM
SDK...just in case you haven't been in touch with us yet I'm posting here. First try another receiver. If it's still not working, unplug the ESC from the receiver, plug your battery into the ESC, and use a voltmeter to check the output between the red and black wires on the receiver plug coming off the ESC. You should be getting 4.8-5v. Let me know what you find, and we'll go from there.

02-18-2007, 11:31 PM
Hi SDK: I'd appreciate it if you would keep me posted as to what you find. From your description, it sounds like I had the same problem. I unmounted the rx, motor, and esc from the heli, and then tried to cycle it up, and lo and behold, it seemed to work fine. I don't suppose that helps much, but I would be interested in finding out what you find. Incidently, I have a heat sink on the esc, if that makes any difference. jdmflyer.

02-20-2007, 11:48 PM
Hi SDK: An additional post w/r to the blinking light on the phoenix 35. After I had dismounted some of the equipment, everything started working OK, so I thought I had probably fixed an intermittant connection, or the like. But then this morning, I went to turn it on again, and the problem was still there, i.e. everything seemed to work except the throtle wouldn't respond, and the 35's led was blinking. I was careful to make sure the throtle stick was in the brake position and set to zero. I was trying a few things and decided to adjust the throtle trim down, and when I got to about 8 increments down, all of a sudden I heard the 35 arm, ( a series of 3 beeps, twice in a row, rather quickly) and it then worked OK. So far, it seems to continue to work OK. I'm guessing that my transmitter has to be set for a below zero throtle posotion for the 35 to sense it is in brake position. Only a guess, though, since I still have a lot to learn w/r to TX settings. Maybe this will help. If you have any thoughts w/r to my experience, please let me know. Best of luck, Jim.

Joe Ford
03-01-2007, 03:51 AM
Your transmitters PWM signal isn't reaching the PWM required by the ESC until you throttle trim is that far down. If you have a computer programmable transmitter you can simply increase the endpoint adjustment on the low side of the throttle channel...same function. :)