View Full Version : Stuck in idle

07-02-2008, 12:59 AM
I was flying my T-rex 450SA and landed and changed the battery I flew for about two minutes and landed.When I went to take off again the heli would only idle.It starts to spool up then slows down then starts to spool up then slows down,thats all it does now.I noticed when I plug the battery in it doesn't make the confirmation sounds any more.All servos are working properly,it just won't spool up to rpm. ________

07-02-2008, 01:20 AM
have you made sure the batteries are fully charged and balanced? i had the same problem w/ my blade 400 and i realized that the battery wasnt fully charged and the LVC on the esc wouldnt allow the esc to arm.

07-02-2008, 03:11 AM
also make sure throttle is in off position

07-02-2008, 05:47 PM
Just tried to reprogram the esc. and got no tones at all when I plugged the battery in.I tried three different batteries with the same results.I checked all the connections as good as I can with the heat shrinks still on,but no loose wires as far as I can see.No tones when I plug in power, and just a idle when I try to spool up.What is a good esc. to buy,I have an Align RCE-BL25X/35X.How do I program the new esc.to my transmitter(DX6)?Do I have to rebind the transmitter? I would like to thank every one for the help.

07-02-2008, 11:11 PM
do you by change have throttle hold lever on tx on?
just a thought

07-09-2008, 01:11 AM
My Align RCE-BL35X lost It's govenor settings once and it surges on govenor, don't like them at all. Think I'll try a Pheonix 35 next.