View Full Version : ESC problems HELP

08-26-2010, 03:38 AM
I have a turnigy plush 30 amp ESC every time I connect it makes normal procedure beeps, after that it keeps with intermitent beeps and does not recognize number of cells (e.g. 3 cell lipos = 3 beeps) in last step before arming the engine.

I removed the shrink tube and look at the circuit, there is nothing burned you can see, also checked the wires to be ok.

It used to work ok, not anymore.

What could the problem be, Is there a way to fix it :confused:

08-26-2010, 04:11 AM
check the throttle trim,it may be to high and not allowing the arming sequnce to finnish. turnigy plush are great esc's and are all i really use except for a few cheapo's i had before using plushes.

08-26-2010, 01:13 PM
Maybe your throttle is reversed on your TX? Any dodgy connections? All well soldered and clean fitting?

My guess is the throttle reversed, is not at neutral when you plug in the battery, trim is too high, or you have some dodgy connectcions. If the ESC was dead, you would probably not get any tones out of it.

Hope you get it sorted!

08-26-2010, 02:19 PM
Mine did that until I taught it the throttle range. Or perhaps I should say until I programmed the throttle range. Then when I changed radios it did it again until I again calibrated the throttle range.

I'm old and may not have the details right, you know how memory can be. So check they manual as it is described well.

As I remeber you

1. turn transmitter on
2. Go to full throttle on transmitter
3. power up esc and listen for beep, beep sequence that indicates it recongnizes full throttle.
4. Then within some time limit you must go to zero throttle. It again gives a beep beep sequence saying it recognizes zero throttle.

After I do that...mine works as advertised.

I'm real new to this. I hope my input helps

08-26-2010, 05:04 PM
Thanks guys have tried all of the above and esc still doesnt arm on cell numbers & engine in last step.

Have tried programing with turnigy card only way it stops beeps in last step is when I set it high start mode, with futaba Tx's you have to reverse throt to work right I use Spektrum.

This is a real mistery it was working all right, cant figure out what is wrong.

Any more ideas are welcome.

08-26-2010, 05:39 PM
Still check to make sure you didn't accidentally reverse the throttle on your TX. this really really sounds like throttle is reversed.

08-26-2010, 06:53 PM
Thanks guys problem is solved , one of wires going to engine was broken inside so this made a false contact, replaced all of them just to make sure it will not fail again.

08-26-2010, 07:24 PM
Try rebinding your Rx. I have had to do this a couple of times.

09-26-2010, 06:37 AM
take the esc with your transmitter to a local hobby shop or go to web sight it has to be programed to your radio.