WattFlyer RC Electric Flight Forums - Discuss radio control eflight

WattFlyer RC Electric Flight Forums - Discuss radio control eflight (https://www.wattflyer.com/forums/index.php)
-   General Electric Discussions (https://www.wattflyer.com/forums/forumdisplay.php?f=3)
-   -   Help w/ Apprentice S 15e (https://www.wattflyer.com/forums/showthread.php?t=73848)

bcmiles 06-07-2014 05:09 AM

Help w/ Apprentice S 15e
I'm having a problem with my Apprentice S 15e. I went flying today and after plugging in the battery, switching on the transmitter, setting the airplane on a flat surface and turning on the switch, nothing happened. I repeated the process and tried turing on the transmitter before the airplane and still nothing. I flew last weekend w/ no issues and the plane has been sitting in my garage since.

When the battery is plugged in the plane, I get the 3 beeps and that is. Whenever the battery is plugged into the Apprentice, the planes flight controls move and the gyroscope (or whatever that thing is) makes a humming sound. My plane isn't doing any of that. The motor and all servos aren't responding. There isn't a light illuminating on the ESC, should there be? I checked all of the connections and everything appears to be solid. The battery is fully charged and checks out on a volt meter. The battery's in the transmitter are good too. I made sure that my throttle was at 0% before turning anything on. How can I diagnose this issue? I have a volt meter handy.

Sorry if this is covered somewhere else, I searched but didn't find anything. I'm fairly new to the sport but am somewhat tech savvy.

bcmiles 06-07-2014 05:33 AM

Sorry, I think I have some of my terminology mixed. I meant the RECEIVER doesn't have an illuminated light, should it have one?

xmech2k 06-07-2014 05:39 AM

Hi bc. First, standard safe practice is always turn tx on first and off last. I guess you're kind of doing that because you're turning the plane on with the switch after the tx, but just remember in the future, most planes are on when the battery gets plugged in. I could see how the new Apprentice could create a bar habit.

It sounds like your esc is getting power from the battery but maybe not your rx. The esc doesn't have a light but the rx does. If the light on the rx comes on solid, it should be ok and is sensing the tx. Is the rx light on at all? If it's flashing, it could mean different things depending on the rate of flash. A fast blinking means it's in bind mode. (You removed the bind plug, right? ) I don't know if you can get a slow flash at power up off the top of my head. Have to check the rx manual for that.

If the rx light is not coming on at all, it's not getting power. Possibly a bad switch. First thing though, have you messed with any connectors recently? Make sure they are plugged in with correct polarity.

Hope something there helps. Good luck and let us know how it goes.

bcmiles 06-07-2014 05:45 AM

Thanks for the tip xmech. Correct, the rx doesn't have a light on at all. I checked all connections and everything is matched correctly and snug. Any tips on how to start diagnosing the issue and find the faulty part?

bcmiles 06-07-2014 05:56 AM

Holy crap....I figured it out. I spoke too soon about polarity, I had the plug coming from the ESC to the rx backwards... I guess in the process of checking the connections I plugged the power in backwards. Everything works fine now. Big dummy!

xmech2k 06-07-2014 08:35 AM

Glad you got it figured out. Don't feel bad, I think everyone has done that at some point! Over the years, I've learned when troubleshooting anything, first I think if I've done anything that may have led to the problem. Then go for the most likely (Like the switch in your system that is a mechanical thing that gets worked, and can fail.), and then easiest to test stuff.

All times are GMT +1. The time now is 05:03 PM.

Powered by: vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2005 WattfFlyer.com
RCU Eflight HQ

Page generated in 0.03746 seconds with 12 queries