Search: Posts Made By: pilotmikey96
Showing results 1 to 4 of 4
Search took 0.00 seconds.
08-10-2009, 07:29 PM
Replies: 6
Views: 2,390
Posted By pilotmikey96

i have took it to a different model shop from the...

i have took it to a different model shop from the one i brought it from for volt testing and the voltage is unusualy low and it seems not to be charging, the person at this model shop said take it...
08-09-2009, 10:36 PM
Replies: 6
Views: 2,390
Posted By pilotmikey96

reply

i did try the other battery straight after to make sure i havent broke my airplane and it works perfectly.
il check it with a voltmeter as soon as i can and i will store it in the shed for now....
08-09-2009, 10:28 PM
Replies: 6
Views: 2,390
Posted By pilotmikey96

reply

thanks for the reply
it works on the other battery just not on this one, dont see how it can be the reciever?
michael
08-09-2009, 09:52 PM
Replies: 6
Views: 2,390
Posted By pilotmikey96

strange behavior from a new battery???

i brought this new li-po 1250mAh 11.1V battery from the local model shop and ive charged it up but when i put it inside my aircraft (cessna ep 400 CML) it makes a strange noise, the rudder struggles...
Showing results 1 to 4 of 4


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.04280 seconds with 7 queries