View Single Post
Old 04-01-2014, 11:17 PM   #1
Join Date: Feb 2014
Location: Upstate NY
Posts: 28
Thanked 0 Times in 0 Posts
iTrader: (0)
Friends: (0)
Default Help! Hawk Sky motor won't run.

It did but now it doesn't
I have a new RTF Hawk Sky which I assembled and had everything working just fine. The receiver and Tx bound, all servos worked as they should and the motor responded well to the throttle. Today I finally got a chance to maiden so I went through my binding routine and checked everything out again. Perfect. Before launching I decided to give it a little glide test to see if the CG seemed right. It nosed down from shoulder height, but not very hard, onto grass.
Now I can't get the motor to run at all. It just twitches back and forth. I've tried re-binding it many times with varying results. The motor never actually runs, but sometimes one of the aileron servos ends up in the down position and won't respond to the stick. Sometimes all control surfaces work fine. Sometimes the rudder doesn't respond.
For a plane that's supposed to take a licking and keep on ticking, it's hard to believe this tiny crash caused so much chaos. Any and all advice would be welcome!
Brewerpaul is offline  
  Reply With Quote
Page generated in 0.03966 seconds with 16 queries