E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Having problems with my new blade cx2 heli

Old 12-27-2008, 07:10 PM
  #1  
cbflight92
New Member
Thread Starter
 
Join Date: Dec 2008
Posts: 2
Default Having problems with my new blade cx2 heli

I have just bought the aluminum lower rotor head for my blade cx2 and i can figure out how to put it on, i can not get the shaft out to put it on or anything so please would somebody inform me how to do this or give me a link
cbflight92 is offline  
Old 12-27-2008, 07:37 PM
  #2  
theecoop
Member
 
theecoop's Avatar
 
Join Date: Jun 2007
Location: michigan
Posts: 640
Default

look here. http://www.dacaur.com/heli/bcxhelp/BladeCXAssembly.pdf
theecoop is offline  
Old 01-12-2009, 05:33 PM
  #3  
schreydog
Member
 
Join Date: Feb 2008
Posts: 28
Default aluminum rotor

you don't have to remove the shaft, just loosen the two set screws on the bottom gear and pull the inner shaft. remove bearing on top,separate the linkage from the swashplate. loosen the four screws on the old rotor and it will slide off. sometimes you have to get sandpaper to remove burrs. when you put the new one on, do the top screws first as they must line up with the two holes you'll see on the outer shaft. also fyi, if you ever do pull the outer shaft, there is a brass step washer on top of the gear, keep track of this asit won't fly without it. schreydog
schreydog is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cbflight92
General RC E-Heli Talk
2
12-28-2008 12:12 AM
E-Flite Helicopters
2
05-04-2008 06:53 PM
kincito
Beginners - Helis
2
01-19-2008 09:09 PM
jrandazzo
Beginners - Helis
3
11-09-2007 04:31 AM
chadbendixsen
Beginners - Helis
9
04-24-2007 12:58 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Having problems with my new blade cx2 heli


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.05550 seconds with 13 queries