FMA Direct Discuss FMA Direct products or ask your support questions.

PL6 and NiMh batteries

Old 12-19-2015, 12:52 AM
  #1  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default PL6 and NiMh batteries

I am trying to cycle a range of NiMh batteries.
I am using the NiMh Preset 21 from the menu.
The termination is shown at NiCd.

I cannot cycle these batteries as 3 different manufacturers batteries fail with what appears to be early termination.

Am I doing anything wrong?

All of the batteries charge ok on a MAha Powerex charger and work fine under load.

Last edited by Derek Morton; 12-19-2015 at 01:01 AM. Reason: extra information
Derek Morton is offline  
Old 12-19-2015, 08:45 AM
  #2  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

If its terminating early during the charge cycle, its possible the cells need to go through a forming cycle. If its terminating early on the discharge, it could be because the discharge current is too high and there is significant voltage drop across the wires.

If you are mixing cells in cell holder and charging them together, its possible the cells are a different states of charge. The charger terminates when fallback voltage is detected. It may trigger one or more cells reaches the fully charged state. If you have the FUIM3, you can chart the fallback voltage. That will give you a little more insight into what is going on.

To perform a forming charge, charge the pack at slow rate, about 100ma-200ma. This will take about 12 to 14 hours.
Gregor is offline  
Old 12-19-2015, 10:00 PM
  #3  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

Let me say again:-

I am using the NiMh Preset 21 from the menu.
The termination is shown as NiCd.

Last edited by Derek Morton; 12-19-2015 at 10:00 PM. Reason: spelling
Derek Morton is offline  
Old 12-19-2015, 10:23 PM
  #4  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

What is the failure? Is happening during charge or discharge?
Gregor is offline  
Old 12-19-2015, 11:25 PM
  #5  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

Originally Posted by Derek Morton View Post
Let me say again:-

I am using the NiMh Preset 21 from the menu.
The termination is shown as NiCd.
That is the correct preset for NiMh cells. Depending on details of your issues, you many need to tune the settings, change the way you are connecting to the charger, or run through a forming charge (preset #22). More details about the failure would help me narrow down what you need to do to move forward.
Gregor is offline  
Old 12-20-2015, 02:31 AM
  #6  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

Hi Gregor,

The charge or discharge stop after 5mah.
Starting again does the same thing.

Starting a forming run on a single cell now.
Derek Morton is offline  
Old 12-20-2015, 03:10 AM
  #7  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

Sounds good. One thing to be aware of. The internal discharge circuit has a minimum voltage of 3v. So you will need at least a 3s pack to discharge each cell down to 1v. You can use regenerative discharge mode if want to discharge 1s, or 2s NiXX.


After the forming charge, I would discharge at 500ma to help reduce voltage drop of the connections.
Gregor is offline  
Old 12-20-2015, 03:13 AM
  #8  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

my first test battery is a 1300mah Duracell aa
Derek Morton is offline  
Old 12-20-2015, 03:33 AM
  #9  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

I am using preset 25 copied to normal 25 without changes.

The chemistry comes up as NiCd and no way to change it.

Regenerative discharge stops after 2 min 9 seconds, at 1.33 v
Derek Morton is offline  
Old 12-20-2015, 05:30 AM
  #10  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

The trickle charge will take 12-14 hours. The trickle preset can be used on NiCad or NiMh.

The default setting is to discharge at 1 amp to 1v. If watch the discharge it's likely discharging to 1v then stopping the charge. Shortly after the load lifted the voltage may jump back up. This caused by either high IR in the cell, or high resistance in the wiring between the cell and the charger.

You didn't mention the discharge current being used. If you are using the default, I would retry at 500ma, or 250ma. If have the FUIM and can save a log, I'm happy to take a look at it you'd be willing to send it to me.
Gregor is offline  
Old 12-20-2015, 05:48 AM
  #11  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

I am running a discharge at 100ma to see what it does.
Then it will run a charge at 100ma and see what it does.
I will save a graph of the charge.
Derek Morton is offline  
Old 12-22-2015, 08:53 AM
  #12  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

discharge graph at 100ma
Attached Files
File Type: zip
NiCd Graph.zip (144.3 KB, 39 views)
Derek Morton is offline  
Old 12-24-2015, 04:55 AM
  #13  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

This looks pretty good. The discharge terminated at 12 hours and about 1.2v. Total discharge was 1197 mah. Based on the discharge curve there was not much more in pack.

The default discharge timeout is 12 hours (set on the safety tab). I would try increasing that to one day, or increase the discharge rate slightly. Also double check the discharge termination voltage. The default is 1v.
Gregor is offline  
Old 12-29-2015, 05:28 AM
  #14  
Derek Morton
New Member
Thread Starter
 
Join Date: Nov 2015
Location: Eltham Australia
Posts: 8
Default

While comparing my 2 chargers, I notice that the maha max voltage was 1.46v, while the pl6 was 1.72v.

The maha has the contacts for the batteries within its body, so I assume very little voltage drop.

The pl6 has an attached device which I modified ( over 10 years ago ) to suit the aa and aaa batteries that I am charging. The voltage drop is coming from the cables that I am using.

I will rework the battery holder to reduce that voltage drop.

Thanks for your help.
Derek Morton is offline  
Old 12-29-2015, 06:27 AM
  #15  
Gregor
Member
 
Join Date: Sep 2007
Posts: 65
Default

Sounds good. I also found it difficult to setup a good high current AA and AAA holder. Most of the battery holders for that size have tiny wires, and springs. Lots of voltage drop as well as heating for higher currents.

The voltage drop will be an issue during discharge. But not during a charge cycle. The Powerlab does not terminate the NiXX program using cell voltage. It uses fallback voltage. The exception to this is if the voltage reaches the maximum per cell voltage of 1.90v.

The other thing that I found useful is selecting fixed cell count instead of using auto detect.
Gregor is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kaborkian
FMA Direct
1
05-12-2014 02:41 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: PL6 and NiMh batteries


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.08595 seconds with 11 queries