My E-Flight AT-6 Power setup problems - WattFlyer RC Electric Flight Forums - Discuss radio control eflight

Power Systems Talk about motors, ESC speed controllers, gear drives, propellers, power system simulators and all power system related topics

My E-Flight AT-6 Power setup problems

 
Prev Previous Post   Next Post Next
Old 01-04-2009, 12:14 PM
  #1  
Shaggy
Member
 
Join Date: Aug 2008
Posts: 55
Default My E-Flight AT-6 Power setup problems

Hello everyone, I have a dualsky 650w motor in my plane with a 3S 4350msh lipo batter and a 12x8 prop not I but it up to full power and it is pulling 300w at about 27amp not this does not seem enough, the motor is rated at 25amps, what can I do? as I do not want it to be under powered or burn it out.
Shaggy is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cookie0664
E-Flite Helicopters
6
10-30-2008 10:15 PM
sosoro
Beginners - Helis
4
11-12-2007 07:16 PM
bert269
RC Radios, Transmitters, Receivers, Servos, gyros
11
06-05-2007 10:30 AM
rccliff
Beginners
1
03-13-2006 01:22 PM
wilscor41
Power Systems
22
02-05-2006 02:41 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Quick Reply: My E-Flight AT-6 Power setup problems


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.10498 seconds with 13 queries