General RC E-Heli Talk General discussion forum for electric powered rc helis.

Rotating nose left align 450 pro

Old 08-09-2011, 10:11 PM
  #1  
PKNEC
New Member
Thread Starter
 
Join Date: Aug 2011
Posts: 17
Default Rotating nose left align 450 pro

Ok folks I have a problem with a new build and I am puzzled as to what to do to resolve the issue.
Heli keeps rotating nose left it's the pro version with align 780 gyro
On the ground with sticks at centre the tail is centered and the servo arm is at 90.
I have repeatedly done the limit check and all is fine with no binding.
I am using a Futaba 7c tx and 617 rx
Using opposite trim doesn't seem to help.
Any help greatly appreciated
cheers,
Paul
PKNEC is offline  
Old 08-10-2011, 03:18 AM
  #2  
RUSH
Member
 
RUSH's Avatar
 
Join Date: Jan 2006
Location: Los Angeles, CA
Posts: 356
Default

Is it spinning uncontrollably, or just a slow drift? If uncontrollably, try reversing the gyro output to the servo.

If it's just drifting, then it's possible that you're bumping the heli on plugging it in which is giving the gyro a false center when it boots up. Also check if it's in heading hold mode.
RUSH is offline  
Old 08-10-2011, 06:09 AM
  #3  
PKNEC
New Member
Thread Starter
 
Join Date: Aug 2011
Posts: 17
Default

Thanks for your reply Rush.
The action of the heli is a slow drift which can be counteracted with a tiny bit of right rudder to keep it centered.
How can I check for heading hold mode.
Cheers,
Paul
PKNEC is offline  
Old 08-10-2011, 08:47 AM
  #4  
RUSH
Member
 
RUSH's Avatar
 
Join Date: Jan 2006
Location: Los Angeles, CA
Posts: 356
Default

Should be set up from the channel you plugged the gain wire into on the rx (ch 5). The radio has a gyro gain menu that you can change. Any gain from 50% to 100% is heading hold - below is for rate mode which will drift if you don't set up the linkage mechanically to stop it. Try 80% and see if that works then if the tail wags quickly, lower it till it stops. Or if the tail either doesn't wag or wags really slowly back and forth make it higher till it starts to wag quickly then back off a little.

Try looking up Finless Bob's videos too - he has some great setup vids if you need them. Or if I'm not making sense

I know a lot of people have had problems with the qc on these, hopefully you won't, but keep that in mind as well.
RUSH is offline  
Old 09-10-2011, 01:23 AM
  #5  
th0rg0d
Fan Junkie/Heli Novice
 
th0rg0d's Avatar
 
Join Date: Dec 2006
Location: Seattle, Wa
Posts: 16
Default

Paul,
I don't know if you solved your problem, but one thing I was taught was that with rudder centered, arm at 90*, you should have 2-3* pitch in tail blades. Also assuming everything was built correctly, I would check for proper belt tension. Too tight or loose could cause either binding, or slippage respectively, which would prevent the tail from achieving proper rotor speed. Let us know if you've already solved your problem.

Thor
th0rg0d is offline  
Old 09-10-2011, 05:12 PM
  #6  
PKNEC
New Member
Thread Starter
 
Join Date: Aug 2011
Posts: 17
Default

Hi mate been out of action for a week or two due to a wipe out.
It was caused by the vertical stabiliser mounting which has a pin that is supposed to locate through the tail mount and boom but for some reason it either wasnt long enough in the first place or has sheared off and caused the tail to rotate leading to a crash.
Metal version on order.
But when i do get it back up i will build in a little offset on the tail and see if that solves the issue.
Cheers,
Paul
PKNEC is offline  
Old 09-15-2011, 04:40 AM
  #7  
th0rg0d
Fan Junkie/Heli Novice
 
th0rg0d's Avatar
 
Join Date: Dec 2006
Location: Seattle, Wa
Posts: 16
Default

Sorry to hear that. Hope you get up in the air soon!!
th0rg0d is offline  
Old 09-15-2011, 01:50 PM
  #8  
solentlife
Super Contributor
 
solentlife's Avatar
 
Join Date: Oct 2010
Location: Ex UK Brit now in Latvia west coast - Ventspils
Posts: 12,553
Default

Originally Posted by RUSH View Post
....... The radio has a gyro gain menu that you can change. Any gain from 50% to 100% is heading hold - below is for rate mode which will drift if you don't set up the linkage mechanically to stop it.......
I would like to point out here that many posts talk about HH and rate settings on radios and make one error repeatedly ...

NOT all radios are 50% and above Heading Hold and 49% to less on rate mode.

There are many radios out there that actually have +0 up to +100% on Heading Hold and -0 down to -100% for Rate mode ...

Not saying this thread radio is that way ... but it pays to read the manual to make sure of what settings ranges are actual for the radio.
solentlife is online now  
Old 09-15-2011, 03:22 PM
  #9  
th0rg0d
Fan Junkie/Heli Novice
 
th0rg0d's Avatar
 
Join Date: Dec 2006
Location: Seattle, Wa
Posts: 16
Default

Great point! Are you insinuating that everyone doesn't fly with a Spectrum? Blasphemy!!
th0rg0d is offline  
Old 09-16-2011, 03:10 AM
  #10  
solentlife
Super Contributor
 
solentlife's Avatar
 
Join Date: Oct 2010
Location: Ex UK Brit now in Latvia west coast - Ventspils
Posts: 12,553
Default

Originally Posted by th0rg0d View Post
Great point! Are you insinuating that everyone doesn't fly with a Spectrum? Blasphemy!!
OMG !! Is that possible ??

To be honest I fly with :

RTF Lanyu cheapo Chinese 35Mhz ... about $15 for fixed wing

RTF 6EHP CP Helicopter 2.4Ghz radio ... about $50 for 450 CP Heli

FlySky 9X with FrSky module .... about $150 incl. FrSky change for multiple fixed wing and heli 450

Jr Propo SSS 35Mhz from 1980's ..... about $600 then !! for fixed wing, when I get my replacement xtals.

Spektrum ... who are they ? There are OTHER radios out there that don't have plastic clips holding trim buttons etc. !! :rolle yes:
solentlife is online now  
Old 09-28-2011, 12:49 AM
  #11  
th0rg0d
Fan Junkie/Heli Novice
 
th0rg0d's Avatar
 
Join Date: Dec 2006
Location: Seattle, Wa
Posts: 16
Default

Paul,
I now own a 780, so maybe I can better help trouble shoot your problem. Once the gyro initializes, if the light is green, you're in heading hold. If the light is red, you're in rate mode. I'm speculating here, but I'm guessing you are drifting in heading hold. Do you have any subtrim dialed in on your rudder channel? Also, verify that the gyro is set for the correct servo signal for your servo. Did you set the travel adjust through the gyro, or via your transmitter?
Those are the things I'd check first, if you are mechanically sound.
th0rg0d is offline  
Old 10-14-2011, 11:40 AM
  #12  
solentlife
Super Contributor
 
solentlife's Avatar
 
Join Date: Oct 2010
Location: Ex UK Brit now in Latvia west coast - Ventspils
Posts: 12,553
Default

Haven't heard anything back from the guy as to whether he's fixed it ...

But will make a comment after reading last post ... Gyros HATE any trim adjustment you make on Tx ... that makes the Gyro hunt and drift or wandering can result.
Always let the Gyro hold the direction ... NOT you unless it needs input from STICK to correct or change direction.

I never thought about this until it was pointed out to me by an experienced Trex flyer ...
solentlife is online now  
Old 10-14-2011, 08:43 PM
  #13  
PKNEC
New Member
Thread Starter
 
Join Date: Aug 2011
Posts: 17
Default

Right lads looks like the problem is solved, amazing what a good wipeout can solve. Lol
Anyway after repairing it ( and it was the cheap plastic vertical stabiliser mount that broke) I set the gyro up as the manual plus in rate mode then switched to HH mode and so far so good, now we just need some decent weather to fly.
Cheers all for your input and I will report back in a week or so weather dependant on the progress.
PB
PKNEC is offline  
Old 10-14-2011, 08:56 PM
  #14  
th0rg0d
Fan Junkie/Heli Novice
 
th0rg0d's Avatar
 
Join Date: Dec 2006
Location: Seattle, Wa
Posts: 16
Default

Good to hear! I hope you were able to figure out what was wrong or different during the rebuild.
th0rg0d is offline  
Old 12-01-2011, 04:35 PM
  #15  
bobby1699
New Member
 
Join Date: Dec 2010
Posts: 15
Default

+1 Thorgod . I always built in +2-3* of pitch at neutral stick..
bobby1699 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
smokejohnson
Heads UP RC discussion
308
05-06-2017 04:20 AM
Dannyrevs
Helicopters- Electric For Sale & WTB
1
03-15-2011 04:44 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Rotating nose left align 450 pro


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.08828 seconds with 13 queries