Problems with CORE-RC UDC20 - WattFlyer RC Electric Flight Forums - Discuss radio control eflight

Batteries & Chargers Discuss Li-P, Li-Ion, NiMh, Nicad battery technology and the chargers that juice 'em up!

Problems with CORE-RC UDC20

Old 08-18-2008, 04:53 PM
  #1  
radweld
Member
Thread Starter
 
radweld's Avatar
 
Join Date: Jun 2008
Location: High Wycombe, Bucks, UK
Posts: 190
Default Problems with CORE-RC UDC20

I have had a couple of these chargers, they look like a cone of other units available from Venom, Bantam etc etc. It's a great cheap little charger but mine has suffered exactly the same failure twice now. I don't know if it's something I am doing wrong but on both failures, I just plug an Eflite 1800mah 3S pack into the balance lead, hook up the main charge lead in the same way I have done a hundred times before and within seconds you smell burning. It seams the balance circuit has burnt out because you can no longer balance cells.

Both my chargers failed in the same way. Do you think it's me?

This is the Unit http://www.racing-cars.com/products.asp?recnumber=4855

Cheers
radweld is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kincito
Beginners - Helis
2
01-19-2008 08:09 PM
inventing_man
Scratch and Kit Built Aircraft
3
09-24-2007 12:07 PM
lovespicyfood
Company Discussions
1
09-29-2006 04:05 PM
propnut30
Foamies
6
03-22-2006 09:30 PM
azkeith
Foamies
2
02-24-2006 02:34 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Problems with CORE-RC UDC20


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.09517 seconds with 15 queries