E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Blade CX2 Problem - No Lift, spinning counterclockwise

Old 08-27-2007, 03:33 AM
  #26  
Heli Jim
Grandpa, Golfer, Pilot
 
Heli Jim's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 1,404
Default

Well, heck. You are very welcome.

That's why the forums are here.......we all enjoy the hobby and
we all like to help out our fellow modelers. Everybody is a newbie
once.

Enjoy your vacation and have fun!!!

Stop back and give us an update and also if you have any other problems.

C-ya.........
Heli Jim is offline  
Old 08-29-2007, 08:59 AM
  #27  
singingperry
Member
 
Join Date: Jun 2007
Posts: 193
Default

Just in case there's someone out there who had the same expierience I had with gears grinding and making noise read on. There's an upper steel collar just behind and above the motors on the rotor shaft. Its function is to hold the rotor shaft up so the pinion gears on the motor shafts meshes properly with the drive gears on the rotor shaft. If this collar shifts even slightly the gears don't properly mesh and gear grinding and slipping can occur. Loosen the set screw on the collar,lift up onthe rotor shaft then slide the collar down on the shaft so that the gears mesh well and the collar is snug against the plastic rotor shaft holder(I know this sounds confusing so work with it and you should be able to figure it out) While holding up on the rotor shaft assembly tighten the collar set screw. If you did this correctly you should be able to pull up on the rotor assembly without the rotor shafts moving up and down.
singingperry is offline  
Old 08-31-2007, 09:27 PM
  #28  
TheBum
Still in training
 
Join Date: Jun 2007
Location: McKinney, TX
Posts: 98
Default

Originally Posted by singingperry View Post
Loosen the set screw on the collar,lift up onthe rotor shaft then slide the collar down on the shaft so that the gears mesh well and the collar is snug against the plastic rotor shaft holder
But not too snugly. Ideally, you should feel (but not see) just the tiniest bit of play in the shaft with the collar properly seated; if it's too tight, you can get binding that will severely shorten your flights and can shorten the life of your motors and 4-in-1.
TheBum is offline  
Old 09-08-2007, 08:01 PM
  #29  
yohan753
New Member
Thread Starter
 
Join Date: Mar 2007
Location: Charlotte, NC
Posts: 10
Default

Thanks for the great suggestions everybody.

It turned out to be a stripped Inner Shaft Gear (upper rotor). I spent $3 on a replacement gear and it works great now!! Finally!

Cheers!
yohan753 is offline  
Old 11-29-2007, 06:50 AM
  #30  
hamby03
New Member
 
Join Date: Nov 2007
Posts: 1
Default No lift and heli rotates to the right

Hey Everyone!

I’m new to the forums and fairly new to the sport of RC Helis and this looks like a great place to learn and help others learn. I’m having a similar problem with my Blade CX2 and was hoping someone could help.

I can only get about 12 inches off the ground and my heli is spinning to the right slowly. I’m adjusted the trim and proportional and that’s not helping. I’ve checked and the battery is fully charged and I’ve replaced the inner and outer shafts. I just ordered a new 3 in 1 and I’m hoping that will solve the problem.

Here’s my question; most of the people here have said the problem can be solved by replacing the 4 in 1, but the 4 in 1 consists of 2 parts; the 3 in 1 and the receiver. To solve the problem, do you need to replace the receiver too, or just the 3 in 1? I wouldn’t think the receiver would get damaged as easily as the 3 in 1.

Thanks.
James
hamby03 is offline  
Old 01-15-2008, 10:09 AM
  #31  
Bernie
New Member
 
Join Date: Jan 2008
Posts: 4
Default Helicopters spins but won't lift

Hi singingperry
Thanks so much for your post.
I spent ages trying to figure out what was wrong until I finally started checking on line and found your answer. ( I had just replaced my bottom rotor collar for the 1st time.)
Your suggestion worked like a charm, I tightened up the screws on the collar at the bottom of the shaft, just above the battery, and all was good again.
Thx, Bernie

Bernie is offline  
Old 02-18-2008, 08:00 PM
  #32  
neilg.
Member
 
Join Date: Feb 2008
Posts: 414
Default

i had no liftoff also. i did everything.

perry, don't get a big ego , but i found that the locking collar on the bottom gear has 2 threaded screws that go through the little holes on the gear and lock onto the flat spot on the inner shaft. it looked tight but when i held it and spun top blades, it spun.


HOUSTON, WE HAVE LIFTOFF.

TY
neilg. is offline  
Old 09-17-2012, 06:32 AM
  #33  
Goetz
New Member
 
Join Date: Sep 2012
Posts: 1
Default

Hi yohan753.
I had the exact same problem as you. I found that my outer shaft had a very slight wobble so I replaced it and gave all the bearings a small shot of WD40 and it ran again like it was new. Not 100% sure if it was the Wd40 or the new shaft that fixed the problem. Hope this helps you.
Goetz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
yohan753
E-Flite Helicopters
6
11-04-2009 12:15 AM
runmuc
Beginners - Helis
8
01-27-2008 06:48 AM
Tunez
E-Flite Helicopters
16
10-12-2007 10:35 PM
MrDiscovery
Beginners - Helis
23
10-03-2007 11:28 PM
antman
Beginners - Helis
1
06-23-2007 03:23 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Blade CX2 Problem - No Lift, spinning counterclockwise


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.07151 seconds with 12 queries