Turnigy Accucell-6 won't discharge at 1A. - WattFlyer RC Electric Flight Forums - Discuss radio control eflight

Batteries & Chargers Discuss Li-P, Li-Ion, NiMh, Nicad battery technology and the chargers that juice 'em up!

Turnigy Accucell-6 won't discharge at 1A.

 
Prev Previous Post   Next Post Next
Old 11-05-2008, 09:03 PM
  #1  
HugoW
Member
 
Join Date: Oct 2008
Location: the Netherlands
Posts: 169
Default Turnigy Accucell-6 won't discharge at 1A.

Hi,

I was just trying to discharge a 6S 4000mAh pack with my new Turnigy Accucell-6 device. I set it at 6S, and 1A, but it only discharges at 0,3A. With a 4000mAh pack, new so probably half charged, that takes me 6,7 hours to discharge. Anyone know how to get it to discharge at 1A?

Thanks,

Hugo
HugoW is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BuzzardBait
Power Systems
2
10-29-2008 06:38 PM
intruderwithin
Batteries & Chargers
10
10-06-2008 09:23 PM
albacore
Beginners
14
06-02-2008 02:50 PM
electrodude71
Airplanes - Electric For Sale & WTB
2
05-20-2008 01:59 AM
rleed
Warbird Electrics
7
05-15-2008 03:09 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Turnigy Accucell-6 won't discharge at 1A.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.08679 seconds with 13 queries