E-Flite Helicopters Discuss E-Flite helicopters in this forum such as the Blade CX, Blade CX2, Blade CP Pro and all other E-Flite rc helis.

Blade CX2 Question regarding Main Rotor

Old 12-31-2014, 07:14 PM
  #1  
blauerman
New Member
Thread Starter
 
Join Date: Dec 2014
Posts: 1
Default Blade CX2 Question regarding Main Rotor

Sorry if this a repost, but my search of the forums and google did not provide an answer.

I received a new Blade CX2 for Christmas. This is my first RC Heli so I am a beginner.

Following the manual I have completed the non-motor control test. All servos seemed to function properly.

After disconnecting the flight battery, then turning the transmitter off I reconnected both motor cables ensuring I had the correct polarity (per the manual red to +).

So here is where my issue comes into play. I turned the transmitter back on then attached the flight battery (ensured that throttle was at lowest possible position and throttle trim was as far down as possible.) The main rotor started up at what I believe to be full throttle. The secondary (lower) rotor did not spin.

I have tested it by holding onto the landing skid to keep it down that the throttle does seem to work for the secondary rotor, but no movement of the throttle or throttle trim seems to affect any of the rotor speed for the main rotor.

I also tried to look at all of the motor solder connections and wires to ensure it wasn't shipped with any damage and could not find any.

I tried to call the manufacturer, but they are have not answered or returned any calls yet.

Any help is greatly appreciated!
blauerman is offline  
Old 12-31-2014, 07:53 PM
  #2  
xmech2k
Ya got any Beeman's?
 
xmech2k's Avatar
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 3,098
Default

Hi blauerman and welcome to WF. I was surprised to hear they're still producing those, so I went to the Blade website just to see, and sure enough! I must have got mine like 7 or 8 years ago. Looks like they changed it up a little, as mine had a 4-in-1 controller with the rx built in, while it looks like the new ones have a 3-in-1 with a separate rx. If you go to their page here, Blade CX2 support and scroll down a little in the window, it looks like there's some addendum to that pre-flight setup stuff under the title 3 in 1 Control Unit Mixer. Maybe that'll help? Good luck, and let us know if it works. I had lots of fun with that CX2, but it doesn't see much air time any more.
xmech2k is offline  
Old 12-31-2014, 07:57 PM
  #3  
xmech2k
Ya got any Beeman's?
 
xmech2k's Avatar
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 3,098
Default

Oh, and by the way, on a coaxial rotor heli like the CX2, the upper and lower rotors are both main rotors, as they equally share the load. To control yaw, one speeds up and one slows down.
xmech2k is offline  
Old 12-31-2014, 08:02 PM
  #4  
pizzano
Behold The Renaissance
 
pizzano's Avatar
 
Join Date: May 2012
Location: So. Calif
Posts: 2,316
Default

From my old recollection, when first binding the Blade coax, the throttle trim does not need to be in the lowest setting......all trim tabs should be set in mid positions at bind.......the throttle stick should be either in a full throttle position or down completely...........!

I'd try re-binding the coax again (after re-checking the manual on the throttle stick bind setting).........If that does not work, the issue is in either the battery discharge or reciever combo response.

Also, make sure that the rotors are spinning counter to each other, top clockwise, bottom counter-clockwise......if they are not, it is certainly a reciever issue......and, make sure that both rotors are spinning freely without any friction or cog catching. The rotation of each rotor is dependant of one another.....if one does not spin properly, the other will respond in-kind.
pizzano is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TomKnollRFV
E-Flite Helicopters
9
07-24-2013 08:42 PM
electrodude71
Helicopters- Electric For Sale & WTB
2
05-08-2013 02:43 AM
CHELLIE
Ebay for sale
0
11-28-2012 10:33 AM
jwinters
Beginners - Helis
5
08-21-2011 04:43 PM
dsmtuned
E-Flite Helicopters
3
03-03-2011 03:11 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Blade CX2 Question regarding Main Rotor


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.07675 seconds with 13 queries