Beginners - Helis A forum where beginners can get help on the fundamentals for experts who know their stuff!

No altitude Blade CX

Old 09-09-2007, 05:55 PM
  #1  
Shadow
New Member
Thread Starter
 
Join Date: Aug 2007
Posts: 10
Unhappy No altitude Blade CX

I am experiencing a problem with altitude with my Blade CX. Have replaced both motors, main gear, inner shaft, blades (upper & lower) and checked both batteries and charger. I noticed a decrease in altitude on subsequent battery pacs until it will not even get off the ground. Before this began I had finally adjusted the 4 in 1 so that the nose would stay pointed forward. Prior to that using the trim pots on the xmitter did virtually nothing. By process of elimination I have determined to replace the 4 in 1 as well. Can someone explain what the problem might be? If you feel it's the 4 in 1, please explain how this would affect altitude. Thanks in advance for your input.
Shadow is offline  
Old 09-10-2007, 07:55 AM
  #2  
Insomniac
Member
 
Insomniac's Avatar
 
Join Date: Sep 2007
Location: Australia
Posts: 649
Default

Perhaps the ESC (electronic speed controller) in the 4-in-1 is faulty?
Insomniac is offline  
Old 09-11-2007, 09:04 PM
  #3  
Shadow
New Member
Thread Starter
 
Join Date: Aug 2007
Posts: 10
Smile Blade CX loss of altitude

Just a note of thanks to those of you who had suggestions on how to solve my altitude problem with Blade CX. As it turns out I recalled reading of a similar problem from a member down in Australia. He claimed that the manufacturer had a produced some faulty lower blades so I examined mine and sure enough they were really soft and pliable, much more so than any other blades I had previously used. After installing a new set the problem was better but still could only get a foot or so off the ground. I had installed an upgraded flybar and noticed that the upper blades were tracking high. After tightening up the linkage my heli took off once more. Thanks to this forum I saved myself the needless expense of a new 4 in 1, and time trying to figure out this problem. Am still shopping for a CP heli and undecided which to go for, but this forum gives me much more confidence in being able to address any future problems thanks to the collective knowledge of forum members!
Shadow is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Laszlo
E-Flite Helicopters
12
09-01-2007 01:46 AM
bry2254
General Electric Discussions
2
03-14-2007 03:32 AM
klitton
Beginners - Helis
5
02-18-2007 02:16 AM
Digital Don
E-Flite Helicopters
2
01-26-2007 07:20 AM
jcblough
E-Flite Helicopters
4
07-09-2006 09:36 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: No altitude Blade CX


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.07998 seconds with 13 queries