Beginners - Helis A forum where beginners can get help on the fundamentals for experts who know their stuff!

Blade CX2 servo problem?

Old 12-26-2008, 07:23 PM
  #1  
dpost01
New Member
Thread Starter
 
Join Date: Dec 2008
Location: SHEPHERDSVILLE, KY
Posts: 1
Default Blade CX2 servo problem?

I have a blade CX2 for about two years now with many crashes. Just recently, after repairing some parts, it appears that one of the servos doesnt want to function correctly. It looks like it is stuck in the up position and wont go back to neutral position on its own. I can force the servo arm back down, hit the stick on the remote, and the servo arm sticks back in the up position. As I move the right stick around, one servo functions properly, by moving the arm up and down, but the second one is stuck.

Is this a problem with the servo or is the heli getting a mixed signal from the remote?

Please help. Thanks.
dpost01 is offline  
Old 12-26-2008, 07:35 PM
  #2  
Twmaster
Registered User
 
Twmaster's Avatar
 
Join Date: Aug 2005
Location: Dallas, TX, USA
Posts: 6,632
Default

Hi and welcome to WattFlyer!

It sounds like you indeed do have a bad servo.

You can check it by swapping the two servo leads and observing the servos. If the servo is bad it behave the same while plugged into the other channel. If the 4-in1/3-in-1 is bad the other servo will act the same.

Don't for get to remember (or write down) which servo went in which slot.

Clear enough?

Hope that helps. Let us know if you need more info.
Twmaster is offline  
Old 12-26-2008, 07:53 PM
  #3  
theecoop
Member
 
theecoop's Avatar
 
Join Date: Jun 2007
Location: michigan
Posts: 640
Default

just a thought ,Did you arm servo and set to zero (center before attaching arm?
theecoop is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cnadianut
Micro Sized Electric Helicopters
5
12-14-2008 09:17 PM
bobinnit
E-Flite Helicopters
19
08-05-2008 03:18 AM
treaves
E-Flite Helicopters
4
01-12-2008 08:25 PM
bobkeenan
Beginners - Helis
5
06-16-2007 10:29 PM
Lawn Dart
E-Flite Helicopters
9
11-10-2006 09:11 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: Blade CX2 servo problem?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.08738 seconds with 15 queries