Castle Creations discussion All things Castle

HV-85 esc help needed

Old 11-22-2006, 07:37 PM
  #1  
adwb
Member
Thread Starter
 
Join Date: Nov 2006
Location: bristol England
Posts: 95
Default HV-85 esc help needed

Please can any one suggest what settings on the castlelink software for the following equipment.

Z-power 50t kv-600 motor with a Phoenix HV-85 esc and a 10s A123 battery pack fitted to a Raptor 30.

or

supply a contact for Phoenix as they don't answer emails sent via the support link on their web site.

thank you

adwb
adwb is offline  
Old 11-22-2006, 08:28 PM
  #2  
Joe Ford
Castle Creations Tech
 
Joe Ford's Avatar
 
Join Date: Jun 2006
Location: Olathe, Kansas
Posts: 115
Default

adwb...I answer 99% of the emails here at "the castle"...haven't received one from you for some reason??? Load up the 1.54 software. Settings should be as follows:

soft cutoff
heli fixed or governor high
brake functions are disabled when you choose a heli mode
motor start power med
throttle response low
low timing advance
PWM 13KHz
current limiting disabled
gov gain and spool up speed you'll have to test...start w/factory and adjust as needed/desired

Make SURE you read the instructions on how to setup your transmitter (you should have printed this when you downloaded the new software...it's on the 2nd page that pops up when you download the Castle Link 2.20 software)
Joe Ford is offline  
Old 11-23-2006, 09:04 AM
  #3  
adwb
Member
Thread Starter
 
Join Date: Nov 2006
Location: bristol England
Posts: 95
Wink

Joe thank you for he information.
FYI I have emailed this query 3 times to your support email address from your website the last time being at the same time as this query was logged.
Maybe there is a problem somewhere?
many thanks
Alistair
adwb is offline  
Old 11-23-2006, 01:52 PM
  #4  
Motions
Member
 
Motions's Avatar
 
Join Date: Nov 2005
Location: Tallahassee, FL
Posts: 128
Default

I highly suggest you use standard timing for this motor.
Motions is offline  
Old 11-23-2006, 02:21 PM
  #5  
adwb
Member
Thread Starter
 
Join Date: Nov 2006
Location: bristol England
Posts: 95
Default

Scott,
why do you suggets that it seems to be different form suggestions else where?
Alistair
adwb is offline  
Old 11-23-2006, 03:41 PM
  #6  
Motions
Member
 
Motions's Avatar
 
Join Date: Nov 2005
Location: Tallahassee, FL
Posts: 128
Default

I was told by Gary at TPPacks. I tried low timing when I set mine up but on the Z-power motor it loses quite a bit of power and doesn't run very well. Standard timing is what this motor needs to be optimum.
Motions is offline  
Old 11-23-2006, 06:38 PM
  #7  
adwb
Member
Thread Starter
 
Join Date: Nov 2006
Location: bristol England
Posts: 95
Default

Ok thank you for the advice.
Alistair
Originally Posted by Motions View Post
I was told by Gary at TPPacks. I tried low timing when I set mine up but on the Z-power motor it loses quite a bit of power and doesn't run very well. Standard timing is what this motor needs to be optimum.
adwb is offline  
Old 12-02-2006, 01:00 AM
  #8  
berniew
Castle Creations
 
berniew's Avatar
 
Join Date: Dec 2006
Location: In my head
Posts: 1
Default

Be sure to read the heli software set up page before the download page. It says 'Print This Page for Reference' and goes throught the steps for heli set up with any software above 1.50.

http://www.castlecreations.com/downl...beta_info.html

Bernie
berniew is offline  
Old 12-03-2006, 05:43 PM
  #9  
Rugar
FAA# OUTLAW!
 
Rugar's Avatar
 
Join Date: Jul 2005
Location: San Bernardino, Ca. USA
Posts: 2,621
Thumbs up

Hi Bernie,
Good to see that you signed up and are posting here.
Welcome to WattFlyer!
Rugar is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jimweda
Castle Creations discussion
2
10-01-2008 08:35 AM
rickmartinez
Motors and Speed Controllers for sale & WTB
9
06-17-2008 11:50 PM
adwb
Castle Creations discussion
0
12-27-2007 06:13 PM
rz22g
Motors and Speed Controllers for sale & WTB
0
12-10-2007 01:25 AM
Don McCullough
Castle Creations discussion
1
01-05-2007 03:06 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Quick Reply: HV-85 esc help needed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

Page generated in 0.13608 seconds with 13 queries